Like us on Facebook!

500GB Of Data GONE!

0
1

First off I have a Seagate FreeAgent Pro (500GB). Usually when I unplug it, it powers off on it's own. Today I unplugged it, then proceeded to plug it into my girlfriends laptop to watch a movie from it (Since she is forced to play WoW on my computer).

I got up to go do something, and I tripped over the usb cord and the device fell over. It was laying on the ground to begin with, so it did not fall far. When I went to continue watching the movie, it played for about 10 seconds and then paused. So I looked at the drive in My Computer and everything was missing from it.

I then unplugged it from the laptop, and noticed the light did not shut off. I used the softtouch button to power it off, then plugged it into my computer, and turned it on. It is now not showing up. Not in Explorer, not in device manager, and not in disk management. However, the power is on, but if I unplug it, it again does not power off automatically unless I force it to (either via softtouch button or unplugging the power source).

I have tried using a variety of different USB cables and power supplies, but no luck. The device is only a few months old, and I have a shit load of movies and albums on it that I have yet to enjoy. It also is the main source for when I run linux. So in short, this device is extremely important to me, and Seagates site just gives basic help.


It now makes a humming sound (not a clicking sound) as the computer starts up. I also have a few smaller external drives, and decided to check their status, and yes they work.  I suppose I can contact Seagate tomorrow since the box claims a 5 year warranty.  My guess is that they will want the original purchase receipt, which will take forever to locate.

1d3n717y Uploaded 08/26/2008
  • 982
  • 17
  • 0
  • Flag

COMMENTS

Popular on 07/22/2008
awesome collection of funny  videos pictures galleries and gifs